Вопрос по информатике:
Составить программу для нахождения произведение чисел от 1 до n.
Для циклов:
1)for
2)while
3)until
- 03.07.2018 13:17
- Информатика
- remove_red_eye 6661
- thumb_up 36
Ответы и объяснения 1
//Pascal
var
a, p: word;
i, n: integer;
begin
readln(n);
//цикл for
p := 1;
for i := 1 to n do
p := p * i;
writeln(p);
//цикл while
i := 1;
p := 1;
while i <= n do
begin
p := p * i;
i := i + 1;
end;
writeln(p);
//цикл repeat
i := 1;
p := 1;
repeat
p := p * i;
i := i + 1;
until i > n;
writeln(p);
end.
- 04.07.2018 21:30
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.