Вопрос по информатике:
Помогите в паскале составить программу даны 3 числа если среди них больше чётных то числа удвойте иначе прибавить к числам 1
- 09.02.2018 02:05
- Информатика
- remove_red_eye 13172
- thumb_up 41
Ответы и объяснения 1
Const N = 3;
var a: array[1..N] of integer;
i, x: integer;
begin
x:=0;
for i:=1 to N do begin
read(a[i]);
if a[i] mod 2 = 0 then
x:=x+1;
end;
if 2*x >= N then
for i:=1 to N do begin
a[i]:=a[i]*2;
writeln(a[i]);
end
else
for i:=1 to N do begin
a[i]:=a[i]+1;
writeln(a[i]);
end;
end.
- 01.01.1970 00:00
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.