Вопрос по информатике:
Составьте программу,выводящую на экран все трехзначные натуральные числа, делящиеся на 17 без остатка
- 10.09.2017 05:22
- Информатика
- remove_red_eye 15366
- thumb_up 25
Ответы и объяснения 2
1)
var k:integer;
begin
for k:=100 to 999 do
if k mod 17 = 0 then writeln(k);
end.
2)
var k: integer;
begin
k:=100;
while k mod 17 0 do inc(k);
while k<999 do
begin
writeln(k);
k:=k+17;
end;
end.
Решение:
102
119
136
153
...
952
969
986
- 11.09.2017 04:33
- thumb_up 13
// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
begin
Range(100,999).Where(n->(n mod 17=0)).Print
end.
Результат выполнения программы:
102 119 136 153 170 187 204 221 238 255 272 289 306 323 340 357 374 391 408 425 442 459 476 493 510 527 544 561 578 595 612 629 646 663 680 697 714 731 748 765 782 799 816 833 850 867 884 901 918 935 952 969 986
- 12.09.2017 10:49
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.