Вопрос по информатике:
Составить программу которая определяет количество чисел в интервале от 100 до 1000 одновременно делящихся на 5 и 21
- 19.06.2018 21:23
- Информатика
- remove_red_eye 16061
- thumb_up 44
Ответы и объяснения 1
Пример, когда лучше сначала подумать, а потом писать программу.
Если число делится одновременно на 5 и 21, то оно делится и на их произведение, т.е. на 105.
Количество таких чисел на указанном интервале может быть найдено как
Здесь "скобки" означают операцию взятия целой части.
Т.е. ответ уже получен, но раз требуется программа, то можно её написать так:
// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
begin
Writeln((1000-105) div 105 + 1)
end.
- 20.06.2018 12:06
- thumb_up 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.