Вопрос по информатике:
Составьте программу которая выводит на экран пример на умножение двух однозначных чисел,запрашивает ответ пользователя.проверяет его и выводит
соответсвующиеся сообщения : "Правильно!" либо "Вы ошиблись" .а также правильный результат.Ниже представлен рекомендуемый вид экрана во время работы экрана
Сколько будет 6х7?
Введите ответ и нажмите ->51
Вы ошиблись. 6x7=42
ДЛЯ ПРОГРАММЫ ПАСКАЛЬ
ПОМОГИТЕ ПОЖАЛУЙСТА
- 26.12.2017 07:30
- Информатика
- remove_red_eye 19305
- thumb_up 10
Ответы и объяснения 1
// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
begin
var a:=Random(1,9);
var b:=Random(1,9);
Writeln('Сколько будет ',a,'x',b,'?' );
var c:=ReadInteger('Введите ответ и нажмите Enter ->');
if c=a*b then Writeln('Правильно!')
else Writeln('Вы ошиблись, ',a,'x',b,'=',a*b)
end.
Тестовые примеры:
Сколько будет 7x4?
Введите ответ и нажмите Enter -> 28
Правильно!
Сколько будет 8x7?
Введите ответ и нажмите Enter -> 65
Вы ошиблись, 8x7=56
- 27.12.2017 22:57
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.