Вопрос по информатике:
Составить программу определяющую можно ли построить прямоугольник по четырем заданным отрезкам
- 09.12.2015 11:32
- Информатика
- remove_red_eye 3985
- thumb_up 46
Ответы и объяснения 1
// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
begin
var a:=ReadArrInteger('Введите стороны',4).Sorted.ToArray;
if (a[0]=a[1]) and (a[2]=a[3])
then Writeln('Можно построить прямоугольник')
else Writeln('Нельзя построить прямоугольник')
end.
Тестовые решения:
Введите стороны 6 12 12 6
Можно построить прямоугольник
Введите стороны 6 12 12 7
Нельзя построить прямоугольник
- 01.01.1970 00:00
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.