Вопрос по информатике:
Есть ли в массиве элементы, равные числу, введённому пользователем?
Паскаль. Помогите составить программу и оформить ответ!
- 19.05.2017 10:44
- Информатика
- remove_red_eye 7085
- thumb_up 46
Ответы и объяснения 2
Var a: array[1..10] of real;
x: real;
a, i: integer;
begin
a:=0;
for i:=1 to 10 do begin
readln(a[i]);
if a[i] = x then
a:=a+1;
end;
if a>0 then
writeln('Таких элементов ', a)
else
writeln('Такого элемента нет');
end.
- 20.05.2017 06:26
- thumb_up 46
Var
a: array[1..100] of integer;
i, j, c: integer;
begin
Writeln('Массив ');
for i := 1 to 100 do begin
a[i] := random(201) - 100;
write(a[i], ' ');
end;
Writeln;
write('Введите число (от -100 до 100) ');
Readln(j);
for i := 1 to 100 do
if a[i] = j then begin c := c + 1; write(i, ' '); end;
Writeln;
if c>1 then write('В массиве число введённое вами есть в массиве и даже несколько (', c, '). Их индексы представлены выше') else if c = 1 then write('Число, которое вы ввели есть в массиве. Его индекс представлен выше') else write('Такого числа в массиве нет');
end.
- 21.05.2017 11:30
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.