Вопрос по информатике:
1.дано целое число n>-10 составьте программу которая вычисляет сумму через от -10 до n
2.дано целое число n (n<100) составьте программу которая вычисляет среднее арифметическое чисел от n до 100
3.дано целое число n>10 составьте программу которая вычисляет сумму через от 10 до n
4.даны действительное число a, натуральное число n, составьте программу которая вычисляет a^n Операцию в возведения в степень не использовать
5. даны целые числа n и m(n<m) составьте программу котрая вычисляет сумму квадратов чисел от n до m
6 данно натуральное число a составьте программу котрая находит сумму( фото формулы под текстом)
- 09.04.2018 03:50
- Информатика
- remove_red_eye 5568
- thumb_up 49
Ответы и объяснения 1
1.
program myprogram;
var n : integer;
a1, a2 : real;
begin readln(n);
writeln((n + 11) * (n - 10) div 2);
end.
2.
program myprogram;
var n : integer;
a1, a2 : real;
begin readln(n);
writeln(((100 - n + 1) * (n + 100) div 2) / (100 - n + 1));
end.
3.
program myprogram;
var n : integer;
a1, a2 : real;
begin readln(n);
writeln((n - 9) * (n + 10) div 2);
end.
4.
program myprogram;
var
n, i : integer;
a1, a2 : real;
begin
read(n);
read(a1);
a2:=a1;
for i:=1 to n do a1:=a1*a2;
writeln(a1);
end.
5.
program myprogram;
var
n,m, i, ans : integer;
begin
read(n);
read(m);
ans:=0;
for i:=n to m do ans := ans + i*i;
writeln(ans);
end.
6.
program myprogram;
var
n, i, ans : integer;
begin
read(n);
ans:=0;
for i:=n to 2*n do ans := ans + i*i;
writeln(ans);
end.
- 01.01.1970 00:00
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.