Вопрос по информатике:
Помогите, пожалуйста!!!
2) Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y – действительные числа) и определяет принадлежность точки заштрихованной области, включая ее границы. Программист торопился и написал программу неправильно. Вот она:
var x,y: real;
begin
readln(x,y);
if y >= -1 then
if y <= sin(x) then
if y >= x-1 then
write('принадлежит')
else
write('не принадлежит')
end.
а) приведите пример таких чисел x, y, при которых программа неверно решает поставленную задачу;
б) укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы; это можно сделать несколькими способами, поэтому можно указать любой способ доработки исходной программы.
- 26.05.2018 11:16
- Информатика
- remove_red_eye 19683
- thumb_up 7
Ответы и объяснения 1
А) при вводе "1 2" программа не выводит ничего.
б)
var x,y: real;
begin
readln(x,y);
if (y >= x - 1) and (y = -1) and (x >= -pi / 2) then
write('принадлежит')
else
write('не принадлежит')
end.
- 27.05.2018 22:25
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.