Вопрос по информатике:
Составьте программу,вычеркивающую из слова Х буквы,встречающиеся при написании слова Х ровно три раза.
- 05.08.2016 09:51
- Информатика
- remove_red_eye 7108
- thumb_up 14
Ответы и объяснения 1
//Pascal ABC.NET v3.1 сборка 1172
Var
s,c:string;
i,k,j,m:integer;
begin
readln(s);
k:=0;
m:=length(s);
i:=0;
while im do
begin;
inc(i);
for j:=i to m do
if s[i]=s[j] then inc(k);
if k=3 then
begin;
c:=s[i];
while pos(c,s)0 do
delete(s,pos(c,s),1);
end;
k:=0;
m:=length(s);
end;
writeln(s);
end.
Пример ввода:
Панамка
Пример вывода:
Пнмк
- 06.08.2016 04:06
- thumb_up 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.