Вопрос по информатике:
Помогите решить задачу с помощью 3-х циклов: 1) "для"; 2) "пока"; 3) "до"
Составить программу подсчета суммы нечетных делителей, кратных
трем, натурального числа N.
- 12.04.2018 20:20
- Информатика
- remove_red_eye 14264
- thumb_up 30
Ответы и объяснения 1
1)
var
i, d, c: integer;
begin
c:=0;
readln(d);
for i:=1 to d do
If (i mod 3 = 0) and (i mod 20) and (d mod i = 0) then
c:=c+i;
writeln(c);
end.
2)
var
i, d, c: integer;
begin
i:=0;
c:=0;
readln(d);
while i<=d do
If (i mod 3 = 0) and (i mod 20) and (d mod i = 0) then begin
c:=c+i;
i:=i+1;
end;
writeln(c);
end.
3)
var i, d, c: integer;
begin
i:=0;
c:=0;
readln(d);
repeat
If (i mod 3 = 0) and (i mod 20) and (d mod i = 0) then begin
c:=c+i;
i:=i+1;
end;
until i
end.
- 13.04.2018 14:48
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.