Вопрос по информатике:
Дано число а. Если а >0 на единицу, иначе уменьшить на 1. Проверить алгоритм для а:=3; а:=0; а:=-12
- 20.02.2018 06:53
- Информатика
- remove_red_eye 2660
- thumb_up 27
Ответы и объяснения 1
Var
a: integer;
begin
readln(a);
if a > 0 then
inc(a)
else
dec(a);
writeln(a);
end.
Входные данные: 3
Выходные данные: 4
Входные данные: 0
Выходные данные: -1
Входные данные: -12
Выходные данные: -13
P.S. Процедура inc(a) увеличивает a на 1, процедура dec(a) уменьшает a на 1.
- 21.02.2018 03:46
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.