Вопрос по информатике:
Дано трехзначное число. Напишите программу, которая определяет: есть ли среди цифр заданного целого трехзначного числа одинаковые.
Пример входных данных и выходных данных:
123 - Нет
121 - Да
222 - Да
В программе использовать div и mod
помогите пожалуйста
- 24.03.2018 13:02
- Информатика
- remove_red_eye 3827
- thumb_up 35
Ответы и объяснения 1
// PascalABC.NET 3.1, сборка 1171 от 15.02.2016
var
n,d1,d2,d3:integer;
begin
Write('n='); Read(n);
d1:=n div 100; d3:= n mod 10;
d2:=(n div 10) mod 10;
if (d1=d2) or (d1=d3) or (d2=d3) then Writeln('Да')
else Writeln('Нет')
end.
Тестовые решения:
n=123
Нет
n=121
Да
n=222
Да
- 25.03.2018 18:04
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.