Вопрос по информатике:
Составьте программу на вычисление суммы числа, цикл с предусловием
- 08.03.2018 05:56
- Информатика
- remove_red_eye 10909
- thumb_up 8
Ответы и объяснения 2
Var
s, n: integer;
begin
readln(n);
s:=0;
while n > 0 do
begin
s:=s + n mod 10;
n:=n div 10;
end;
writeln(s);
end.
- 09.03.2018 05:44
- thumb_up 42
Program Znanija;
uses crt;
var a,b : integer;
begin
readln(b);
a:=0;
while b > 0 do
begin
a:=a + b mod 10;
b:=b div 10;
end:
writeln('Ответ',a );
end
- 01.01.1970 00:00
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.