Вопрос по информатике:
Написать программу нахождения суммы нечётных цифр в натуральном числе. Pascal
- 25.01.2017 06:28
- Информатика
- remove_red_eye 12356
- thumb_up 22
Ответы и объяснения 1
// PascalABC.NET 3.1, сборка 1171 от 15.02.2016
begin
var n:=ReadInteger('n=');
var s:=0;
while n0 do begin
var d:=n mod 10;
if Odd(d) then s+=d;
n:=n div 10
end;
Writeln('Сумма нечетных равна ',s)
end.
Тестовое решение:
n= 25325423
Сумма нечетных равна 16
- 27.01.2017 00:51
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.