Вопрос по информатике:
Составить программу, которая определяет, есть ли среди цифр целого трёхзначного числа одинаковые
- 23.09.2017 13:15
- Информатика
- remove_red_eye 17781
- thumb_up 28
Ответы и объяснения 2
Var
n: integer;
begin
readln(n);
if (n mod 10 = n div 10 mod 10) or (n mod 10 = n div 100) or (n div 10 mod 10 = n div 100) then
writeln('Есть')
else
writeln('Нет');
end.
- 24.09.2017 01:02
- thumb_up 26
А еще есть такое вот "хитрое", но короткое решение:
// PascalABC.NET 3.1, сборка 1171 от 15.02.2016
begin
var s:=ReadInteger('n=').ToString.ToSortedSet;
if s.Count<3 then Writeln('Есть одинаковые цифры')
else Writeln('Нет одинаковых цифр')
end.
Тестовое решение:
n= 141
Есть одинаковые цифры
- 25.09.2017 12:17
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.