Вопрос по информатике:
1) Совершенным называется число, равное сумме всех своих делителей, меньших его самого (например, число 6 = 1 + 2 + 3). Напишите программу, которая вводит натуральное число N и определяет, является ли число N совершенным
- 25.06.2018 18:50
- Информатика
- remove_red_eye 6363
- thumb_up 8
Ответы и объяснения 1
Function Check(a : Integer) : Boolean;
Var i,s : Integer;
Begin
s:=0;
For i:=1 to a-1 do
If a mod i=0 then s:=s+i;
Check:=s=a;
end;
Var N : Integer;
Begin
Readln(N);
Writeln(Check(N));
end.
- 26.06.2018 02:27
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.