Вопрос по информатике:
Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел
(массив не использовать).
Использовать только Repeat
программа ПАСКАЛЬ
40 БАЛЛОВ
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 19.10.2016 05:15
- Информатика
- remove_red_eye 18503
- thumb_up 12
Ответы и объяснения 2
Var
i: integer;
sr, s, x: real;
begin
i:=0;
repeat
readln(x);
s:=s+x;
i:=i+1;
until i=10;
sr := s/10;
writeln(sr);
end.
- 20.10.2016 12:17
- thumb_up 11
Var i, n: integer;
S, k: real;
begin
n := 10;
S := 0;
repeat
writeln('Print number');
readln(k);
S := S + k;
n := n - 1;
until n = 0;
writeln(S / 10);
end.
- 21.10.2016 01:17
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.