Вопрос по информатике:
Программирование циклов :
Составьте программу по которой компьютер десять раз запросит ввод целых чисел и в результате сообщит сколько среди введённых чисел чётных и сколько нечётных
В ПАСКАЛЕ С ИСПОЛЬЗОВАНИЕМ WHILE или REPEAT или FOR только без скобок квадратных , дам 40 БАЛЛОВ
- 14.05.2018 00:16
- Информатика
- remove_red_eye 2221
- thumb_up 29
Ответы и объяснения 1
Var
i, k, x: integer;
begin
k:=0;
for i:=1 to 10 do
begin
readln(x);
if x mod 2 = 0 then //если x четный
inc(k); //увеличиваем k на 1
end;
writeln('Четных: ', k);
writeln('Нечетных: ', 10-k);
end.
- 15.05.2018 04:21
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.