Вопрос по информатике:
Дано число. определить чему равна сумма нечетных цифр в этом числе
- 22.10.2017 23:03
- Информатика
- remove_red_eye 10668
- thumb_up 13
Ответы и объяснения 1
Var
a,s: integer;
begin
readln(a);
s := 0;
while a >0 do
begin
if a mod 10 mod 2 0 then
inc(s, a mod 10);
a := a div 10;
end;
writeln(s);
end.
- 23.10.2017 12:39
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.