Вопрос по информатике:
Электронные часы показывают время в формате h:mm:ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд. Количество минут и секунд при необходимости дополняются до двузначного числа нулями.
С начала суток прошло n секунд. Выведите, что покажут часы.
Входные данные
Вводится целое число n.
Выходные данные
Выведите ответ на задачу, соблюдая требуемый формат.
Примеры
Входные данные
3602
Выходные данные
1:00:02
Входные данные
129700
Выходные данные
12:01:40
- 14.04.2017 01:53
- Информатика
- remove_red_eye 6068
- thumb_up 34
Ответы и объяснения 1
#include "iostream" using namespace std; int main(){ int secound =0; int hh =0; int mm =0; int ss =0; cin >> secound; int temp = secound; for(int i = 0; i <= secound; i++){ if(i == 60){ mm++; i-=60; secound-=60; } if(mm == 60){ hh++; mm=0; } } ss = temp - hh*3600 - mm *60; cout << hh <<":"<< mm << ":" << ss; return 0; }
- 15.04.2017 10:12
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.