Вопрос по информатике:
Напишите программу, которая вводит натуральное число и находит все числа на отрезке [0, N], сумма цифр которых не меняется при умножении числа на
2,3,4,5,6,7,8 и 9 (например, число 9). Используйте функцию для вычисления суммы цифр числа.
- 13.04.2018 14:51
- Информатика
- remove_red_eye 16337
- thumb_up 11
Ответы и объяснения 1
//Pascal ABC.NET v3.0 сборка 1111
Var
n,i:integer;
function sol(a:integer):integer;
var
i,k:integer;
s:string;
begin
k:=0;
str(a,s);
for i:=1 to length(s) do
k:=k+strtoint(s[i]);
sol:=k;
end;
begin
readln(n);
for i:=0 to n do
if (sol(i*2)=sol(i*3)) and (sol(i*3)=sol(i*4)) and (sol(i*4)=sol(i*5)) and (sol(i*5)=sol(i*6)) and (sol(i*6)=sol(i*7)) and (sol(i*7)=sol(i*8)) and (sol(i*8)=sol(i*9)) then writeln(i);
end.
Пример ввода:
555
Пример вывода:
0
9
18
45
90
99
180
198
297
396
450
495
549
- 14.04.2018 03:14
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.