Вопрос по информатике:
[PASKAL] Составить программу вычеркивания из текста всех пробелов
Помогите решить задачу !
- 25.09.2018 07:20
- Информатика
- remove_red_eye 14825
- thumb_up 45
Ответы и объяснения 2
Var
s: string;
i: integer;
begin
readln(s);
for i:=length(s) downto 1 do
if s[i] = ' ' then
delete(s, i, 1);
writeln(s);
end.
Пример входных данных: Мама мыла раму
Пример выходных данных: Мамамылараму
- 26.09.2018 15:20
- thumb_up 14
//Pascal ABC.NET v3.0 сборка 1111
Var
s:string;
begin
readln(s);
while pos(' ',s)0 do
delete(s,pos(' ',s),1);
writeln(s);
end.
Пример ввода:
Cat is fine too
Пример вывода:
Catisfinetoo
- 27.09.2018 01:13
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.