Вопрос по информатике:
Напишите программу, которая вводит с клавиатуры 10 реальных чисел, и организовывает их хранение в массиве. После этого массив пересор- тировывается по закону: первый элемент меняется с последним
- 07.12.2015 04:55
- Информатика
- remove_red_eye 10159
- thumb_up 26
Ответы и объяснения 1
//реальные числа - странное определение чисел вещественного типа
//Pascal ABC.NET v3.0 сборка 1111
Var
ar:array[1..10] of real;
i:integer;
k:real;
begin
writeln('Array:');
for i:=1 to 10 do
readln(ar[i]);
k:=ar[1];
ar[1]:=ar[10];
ar[10]:=k;
writeln('Final array:');
for i:=1 to 10 do
write(ar[i]:4);
end.
Пример ввода:
1
2
..
10
Пример вывода:
Final array:
10 2 3 4 5 6 7 8 9 1
- 08.12.2015 20:08
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.