Вопрос по информатике:
1. Напишите программу, которая находит наименьшее из чисел, крат¬ных трём в последовательности целых чисел. Гарантируется, что в после¬довательности есть хотя бы одно такое число. Программа получает на вход целые числа, количество введённых чисел неизвестно, последова¬тельность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: наименьшее из чисел, кратных. Пример работы программы: Входные данные Выходные данные 12 3 15 2 3 6 0
- 20.08.2015 23:30
- Информатика
- remove_red_eye 17545
- thumb_up 51
Ответы и объяснения 1
Var
a, min: integer;
begin
min :=30000;
repeat
readln(a);
if (a mod 3 = 0) and (a < min) and (a 0) then
min := a;
until a = 0;
writeln(min);
end.
- 21.08.2015 11:53
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.