Вопрос по информатике:
Напишите программу нахождения произведения цифр 5ти значного числа на языке Паскаль. Заранее спасибо)
- 24.08.2015 00:39
- Информатика
- remove_red_eye 18243
- thumb_up 21
Ответы и объяснения 1
Program qqq;
var n, s, x1, z1, i, del: integer;
begin
writeln ('vvedi 5-znachnoe chislo < 32768');
{ограничение типа integer}
readln (n);
del:=10000;
for i:=1 to 5 do
begin
z1:= n mod del;
x1:= n div del;
s:=s+x1;
n:=z1;
del:=del div 10;
end;
writeln ('summa cifr=', s);
readln;
end.
- 25.08.2015 14:58
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.