Вопрос по информатике:
Даны 3 действительных числа. возвести в квадрат те из них, значение которых неотрицательно, а в четвертую степень отрицательные числа. составить программу на языке Паскаль, которая выводит на экран
ответ для введенных с клавиатуры чисел. Протестировать с числами 5,2,1. Решить с помощью условного оператора. Очень срочно. даю 30 баллов!
- 17.10.2017 14:13
- Информатика
- remove_red_eye 18523
- thumb_up 29
Ответы и объяснения 1
Var
a,b,c:real;
begin
read(a,b,c);
writeln;
if a>=0 then writeln(sqr(a)) else writeln(power(a,4));
if b>=0 then writeln(sqr(b)) else writeln(power(b,4));
if c>=0 then writeln(sqr(c)) else writeln(power(c,4));
end.
- 19.10.2017 00:36
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.