Вопрос по информатике:
Найти среднее время,затрачиваемое на выполнение домашнего задания учениками.В классе 24 человека,затрчаиваемое время случайно в диапазоне от 3 до 76 минут.
На языке Паскаль составить программу
- 03.11.2017 00:13
- Информатика
- remove_red_eye 15220
- thumb_up 23
Ответы и объяснения 1
//PascalABC.NET 3.0
begin
var a := ArrRandom(24, 3, 76);
writeln('Затрачиваемое учениками время: ');
a.Println;
writeln('Среднее время: ', a.Average : 0 : 2);
end.
//FPC / Turbo Pascal
var
a, i, sum: integer;
begin
writeln('Затрачиваемое учениками время: ');
for i := 1 to 24 do
begin
a := random(74) + 3;
sum := sum + a;
write(a, ' ');
end;
writeln;
writeln('Среднее время: ', sum / 24 : 0 : 2);
end.
- 04.11.2017 23:37
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.