Вопрос по информатике:
ПОМОГИТЕ ПОЖАЛУЙСТА НАПИСАТЬ ПРОГРАММУ НА ПАСКАЛЕ
Переведите натуральное число из двоичной системы в десятичную (в двоичном числе не более 10 цифр).
Входные данные
Вводится натуральное число, записанное в двоичной системе.
Выходные данные
Выведите число, записанное в десятичной системе.
Примеры
входные данные
1
выходные данные
1
входные данные
1001
выходные данные
9
- 18.05.2016 08:51
- Информатика
- remove_red_eye 10045
- thumb_up 24
Ответы и объяснения 1
{by Puporev}
const digit : string[16] = '0123456789ABCDEF';
Function ToDec(n:string;r:byte) : longint;
var m,i:longint;
begin
m:=0;
for i:=1 to length(n) do
m:=m*r+pos(n[i],digit)-1;
ToDec:=m;
end;
Var S : String;
Begin
Readln(S);
Writeln(ToDec(S,2));
end.
- 19.05.2016 10:56
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.