Вопрос по информатике:
Чему будет равно значение переменной c в результате выполнения фрагмента программы
a:=1257; c:=0;
while a>0 do begin
if a mod 2<>0 then b:=a mod 10; c:=c+b;
a:=a div 10; end;
1) 5;
2) 13;
3) 16;
4) 18.
- 12.05.2017 20:24
- Информатика
- remove_red_eye 1465
- thumb_up 33
Ответы и объяснения 1
Ответ: 18
Обоснование:
Var a,b,c : Integer;
Begin
a:=1257; c:=0;
while a>0 do begin
if a mod 20 then b:=a mod 10; c:=c+b;
a:=a div 10; end;
Writeln(c);
end.
- 14.05.2017 00:27
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.