Вопрос по информатике:
1. Написать программу вычисления площади кольца, где исходными
данными являются радиусы кольца и отверстия. Предусмотреть в
программе проверку правильности исходных данных (радиус отверстия не
может быть больше радиуса кольца). Сделать на паскале и можно в документе прикрепить
- 15.04.2016 11:37
- Информатика
- remove_red_eye 1927
- thumb_up 27
Ответы и объяснения 1
// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
var r1:=abs(ReadReal('Наружный радиус кольца'));
var r2:=abs(ReadReal('Внутренний радиус кольца'));
if (r1*r2>0) and (r1>r2) then
Writeln('Площадь кольца ',pi*(sqr(r1)-sqr(r2)))
else Writeln('Неверные данные')
end.
Тестовое решение:
Наружный радиус кольца 25
Внутренний радиус кольца 21.8
Площадь кольца 470.484915801607
- 16.04.2016 10:31
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.