Вопрос по информатике:
Найдите наибольший по модулю элемент заданного массива из 9 действительных чисел (программка)
Пожаалууйста!!!! очень срочно
- 23.11.2017 01:33
- Информатика
- remove_red_eye 17607
- thumb_up 50
Ответы и объяснения 1
// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
var a:=ReadArrReal('Введите 9 чисел:',9);
var imax:=0;
for var i:=1 to 8 do
if abs(a[i])>abs(a[imax]) then imax:=i;
Writeln('Наибольшее по модулю: ',a[imax])
end.
Тестовое решение:
Введите 9 чисел: 7 13 0 -4 8 13 -7 -14 2
Наибольшее по модулю: -14
- 24.11.2017 11:06
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.