Вопрос по информатике:
Помогите написать программу на C#!
Даны координаты точки А(х1,у1). Определить, принадлежит ли эта точка какой-нибудь оси координат. Если да, то какой.
- 08.12.2015 13:40
- Информатика
- remove_red_eye 19705
- thumb_up 16
Ответы и объяснения 1
Using System;
class Program
{
static void Main()
{
for(var x=-2;x<=2;x++){
for(var y=-2;y<=2;y++){
IsPointOnAxis(x, y);
}
}
Console.ReadKey();
}
static void IsPointOnAxis(int x, int y){
Console.WriteLine("Point = {0}; {1}", x, y);
if (x*y != 0){
Console.WriteLine("Point not on axis");
return;
}
if (x == 0){
Console.WriteLine("Point is on axis Ox");
}else if (y == 0){
Console.WriteLine("Point is on axis Oy");
}
}
}
- 09.12.2015 02:32
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.