Вопрос по информатике:
Напишите программу на языке Паскаль которая выводит порядковый номер минимального элемента в двухмерном массиве
- 25.02.2018 14:54
- Информатика
- remove_red_eye 8288
- thumb_up 18
Ответы и объяснения 1
//Pascal ABC.NET v3.0 сборка 1111
Const
n=10;
Var
ma:array[1..n,1..n] of integer;
min,mini,minj,i,j:integer;
begin
min:=2147483647;
randomize;
writeln('Matrix:');
for i:=1 to n do
begin;
writeln;
for j:=1 to n do
begin;
ma[i,j]:=random(300);
write(ma[i,j]:4);
if min>ma[i,j] then
begin;
min:=ma[i,j];
mini:=i;
minj:=j;
end;
end;
end;
writeln;
write('Строка:',mini,' столбец:',minj);
end.
- 26.02.2018 09:00
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.