Вопрос по информатике:
На каждом следующем дне рождения Винни Пух съедает столько же меда, что и на двух предыдущих. На двух первых днях рождения у Пяточка и у Кролика он съел по 100 г меда. Написать программу, определяющую, сколько килограммов меда съест Винни Пух на -ом дне рождения.
Формат входных данных
Во входном файле задано единственное число (1 до 40).
Формат выходных данных
Выведите, сколько килограммов меда съест Винни Пух на этот день рождения с точностью до одного знака после десятичной точки.
- 17.04.2018 02:30
- Информатика
- remove_red_eye 7726
- thumb_up 19
Ответы и объяснения 1
Var
n,a,b,c,c2,i:integer;
Begin
Write('Введите число ');
Readln(n);
a:=100;
b:=100;
for i:= 1 to n do Begin
c:=a+b; a:=b; b:=c;
End;
c2:=c div 1000;
write(c2,'.');
c:=c div 100 mod 10;
write(c,' кг съел Винни');
End.
- 18.04.2018 13:07
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.