Вопрос по информатике:
Напишите программу, которая вводит номер месяца и выводит название времени года на английском языке. При вводе неверного номера месяца должно быть выведено слово 'NO'.
Входные данные
Входная строка содержит единственное число – номер месяца (возможно, неверный).
Выходные данные
Нужно вывести название времени года (на английском языке), соответствующее введённому номеру месяца ('winter' – зима, 'spring' – весна, 'summer' – лето, 'autumn' – осень). Если введён неверный номер месяца, программы должна вывести слово 'NO'.
- 08.02.2017 18:14
- Информатика
- remove_red_eye 13152
- thumb_up 23
Ответы и объяснения 2
Var n: integer;
begin
read(n);
case n of
12, 1, 2: writeln('winter');
3..5: writeln('spring');
6..8: writeln('summer');
9..11: writeln('autumn');
else writeln('NO')
end
end.
- 09.02.2017 10:53
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.