Вопрос по информатике:
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы. Выходные данные Программа должна вывести сумму, произведение и среднее арифметическое введенных чисел. Среднее арифметическое нужно вывести с точностью 3 знака после десятичной точки (ровно 3 знака с учетом округления).
Примеры
входные данные
4 5 7
выходные данные
4+5+7=16
4*5*7=140
(4+5+7)/3=5.333
- 09.04.2016 17:51
- Информатика
- remove_red_eye 6386
- thumb_up 25
Ответы и объяснения 2
var a,b,c:integer;
begin
read(a,b,c);
writeln(a,'+',b,'+',c,'=',a+b+c);
writeln(a,'*',b,'*',c,'=',a*b*c);
writeln('(',a,'+',b,'+',c,')/3=',(a+b+c)/3:4:3);
end.
- 01.01.1970 00:00
- thumb_up 12
Program Name;
var a,b,c,s,p:integer;
F:real;
begin
readln (a);
readln (b);
readln (c);
s:=a+b+c;
p:=a*b*c;
F:=(a+b+c)/3;
writeln ('s=',a+b+c);
writeln ('p=',a*b*c);
write ('F=',(a+b+c)/3:0:3);
end.
Сумму обозначила буквой s
Произведение обозначила буквой p
Среднее арифметическое обозначила буквой F
- 01.01.1970 00:00
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.