Вопрос по информатике:
!!!!!!!ТОЛЬКО ДЛЯ ЗНАЮЩИХ!!!!!!!!!
Составить программу, которая позволяет ввести два числа в первой строке, и один из знаков (+, -, *, /) во второй строке. На экран должен быть выведен результат выполнения соответствующего арифметического действия. Для ввода знака использовать вспомогательную переменную типа char.
- 11.01.2018 17:08
- Информатика
- remove_red_eye 4645
- thumb_up 17
Ответы и объяснения 2
Var
s: char;
a, b: real;
begin
Write('Введите два числа ');
Readln(a, b);
Write('Введите действие (+, -, *, /) - ');
Readln(s);
case s of
'+': writeln(a, ' + ', b, ' = ', a + b);
'-': writeln(a, ' - ', b, ' = ', a - b);
'*': writeln(a, ' * ', b, ' = ', a * b);
'/': if (b=0) then writeln('На ноль делить нехорошо - бесконечность получится') else writeln(a, ' / ', b, ' = ', a / b);
End;
end.
- 12.01.2018 19:47
- thumb_up 2
Var Ch : Char;
a,b : Integer;
Begin
Readln(a,b);
Readln(Ch);
Case Ch of
'+' : Writeln(a+b);
'-' : Writeln(a-b);
'*' : Writeln(a*b);
'/' : Writeln(a/b);
end;
end.
- 13.01.2018 22:43
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.