Вопрос по информатике:
Составьте задачу в Паскаль с помощью while. На каждом следующем дне рождения Винни Пух съедает столько же меда, сколько съел на двух предыдущих вместе. На двух первых днях рождения у Пятачка и Кролика он съел по 100 г меда. Определите, сколько килограммов меда он съест на десятом дне рождения.
- 22.09.2017 22:38
- Информатика
- remove_red_eye 13461
- thumb_up 41
Ответы и объяснения 1
Числа Фибоначчи (вместо 1 только 100)!
var m1,m2,s,i:integer;
begin
m1:=100; m2:=100;
for i:=3 to 10 do
begin
s:=m1+m2;
m1:=m2;
m2:=s;
end;
writeln(s);
end.
Результат:
5500
- 23.09.2017 13:04
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.