Вопрос по информатике:
Напишите программу, которая из введённого с клавиатуры натурального числа удаляет все цифры 5. Программа получает на вход целое число не превышающее 30000.
Программа должна вывести одно число- число, полученное из исходного, после удаления всех цифр 5 и из его записи.
ПРИМЕР РАБОТЫ ПРОГРАММЫ:
Входные данные-25455
Выходные данные-24
- 16.02.2018 02:47
- Информатика
- remove_red_eye 15762
- thumb_up 26
Ответы и объяснения 1
Var
s, s2: string;
i: integer;
begin
Write('Введите число ');
Readln(s);
for i := 1 to 5 do
if s[i] '5' then
s2 := s2 + s[i];
Writeln(s2);
end.
- 17.02.2018 13:46
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.