Вопрос по информатике:
Добрые люди, помогите, пожалуйста, сделать задачи по информатике.
1. Напишите программу, которая в последовательности натуральных чисел определяет количество всех чётных чисел, кратных 3. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: количество всех чётных чисел, кратных 3.
2. Напишите программу, которая в последовательности натуральных чисел определяет количество всех нечётных чисел, кратных 7. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: количество всех чётных чисел, кратных 7.
- 18.05.2017 05:58
- Информатика
- remove_red_eye 2095
- thumb_up 9
Ответы и объяснения 1
Решение 1-й задачи:
//PascalABC.Net
//NaaMan
var
i, n : integer;
begin
i := 0;
repeat
write('Введите число > ');
readln(n);
if (n > 0) then
if (n mod 2 = 0) then
if (n mod 3 = 0) then i := i + 1;
until (n = 0);
writeln('Количество чётных чисел, кратных 3: ', i)
end.
Для решения второй задачи нужно заменить (n mod 2 = 0) на (n mod 2 = 1) и (n mod 3 = 0) на (n mod 7 = 0).
- 19.05.2017 09:24
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.