Вопрос по информатике:
Написать программу с использованием цикла while. Через каждые пять секунд каждая амеба делиться на две амебы. Изначально была 1 амеба. Сколько амеб будет через N секунд? Проверить решение для 10, 25, 72 секунд.
- 26.07.2017 07:39
- Информатика
- remove_red_eye 2277
- thumb_up 7
Ответы и объяснения 1
Это просто! Вот решение:
Var n,a,time:integer;
Begin
Readln(n);
a:=1;time:=0;
while time
time:=time+1; //èëè âìåñòî ýòîãî " Inc(time); "
End;
Writeln(a);
End.
И результаты проверки:
10 секунд: 4 амёбы
25 секунд: 32 амёбы
72 секунды: 32768 амёбы
- 27.07.2017 18:56
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.