Вопрос по информатике:
Паскаль
procedure F(n: integer);
begin
if n <= 5 then
begin
F(n + 2);
writeln (n);
F(n + 3)
end
end
Чему равна сумма всех чисел, напечатанных на экране при выполнении
вызова F(l)? (И КАК)
- 20.01.2016 18:31
- Информатика
- remove_red_eye 6053
- thumb_up 22
Ответы и объяснения 1
Ответ: 13.
А получается он вот так:
procedure F(n:integer);
begin
Writeln('Вызов F(',n,')');
if n <= 5 then begin
F(n + 2);
writeln('Процедура вывела ',n);
F(n + 3)
end
end;
begin
f(1)
end.
Результат работы программы:
Вызов F(1)
Вызов F(3)
Вызов F(5)
Вызов F(7)
Процедура вывела 5
Вызов F(8)
Процедура вывела 3
Вызов F(6)
Процедура вывела 1
Вызов F(4)
Вызов F(6)
Процедура вывела 4
Вызов F(7)
- 21.01.2016 08:13
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.