Вопрос по информатике:
Составить программу, вычисляющую площадь геометрической фигуры. Тип фигуры определяется символом (с): О – окружность, T – равнобедренный прямоугольный треугольник и K – квадрат. Целое число, вводимое вслед за символом определяет соответствующий элемент для вычисления площади (для окружности это радиус, для треугольника – длина катета, для квадрата – длина стороны).
- 22.10.2017 20:16
- Информатика
- remove_red_eye 1379
- thumb_up 48
Ответы и объяснения 1
Var
S, X, a, b, R: Real;
C: String;
Begin
WriteLn('Chto budem vichislat');
ReadLn(C);
if C = 'O' then begin
WriteLn('Radius');
ReadLn(R);
S:= Pi*sqr(R);
end;
if C:= 'T' then begin
WriteLn('Vvedite 1 katet);
ReadLn(a);
WriteLn('Vvedite 2 katet);
ReadLn(b);
S:= 1/2 * a * b;
end;
if C:= 'K' then begin
WriteLn('Vvedite 1 katet);
ReadLn(a);
S:= sqr(a);
end;
WriteLn('Ploshad = ');
ReadLn(S);
end.
- 23.10.2017 16:02
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.