Вопрос по информатике:
Подскажите пожалуйста. (Для программы Кумир и Паскаль)
Написать программу в процессе выполнения которой, получить случайное трехзначное число и вывести через запятую его отдельные цифры. Пример:
Получено число 123.
Его цифры 1, 2, 3.
Примечание: используйте функцию irand, операции div и mod.
- 07.11.2017 16:37
- Информатика
- remove_red_eye 7865
- thumb_up 17
Ответы и объяснения 1
Решение на паскале:
//PascalABC.NET
//NaaMan
var
n,i:integer;
r,c,s:string;
begin
randomize;
n:=random(100,999);
writeln('Сгенерированное число > ', n);
s:=','; r:='.'; c:='';
for i:=1 to 3 do begin
if (i=3) then s:='';
str(n mod 10,c);
r:=concat(s,c,r);
n:=n div 10;
end;
writeln(r)
end.
- 08.11.2017 00:09
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.