Вопрос по информатике:
У исполнителя калькулятор две команды, которым присвоены номера:
1) прибавь 1;
2) умножь на 4.
Напишите программу, которая вычисляет, сколько существует различных программ, преобразующих число M в число N, оба числа вводятся с клавиатуры.
- 12.01.2018 00:46
- Информатика
- remove_red_eye 9631
- thumb_up 26
Ответы и объяснения 1
{работает для натуральных чисел}
function f(m,n : integer): integer;
begin
if n = m then
f := 1
else
if n < m then
f := 0
else
if (n mod 4 = 0) and (n 0) then
f := f(m,n-1) + f(m,n div 4)
else
f := f(m,n-1)
end;
var
m,n : integer;
begin
read(m,n);
writeln(f(m,n))
end.
- 14.01.2018 00:21
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.