Вопрос по информатике:
Задан массив из 10 целых чисел. Найдите среднее арифметическое всех четных элементов массива. Пожалуйста, составьте программу в паскале:)
- 19.07.2017 21:01
- Информатика
- remove_red_eye 2777
- thumb_up 18
Ответы и объяснения 1
Задачка в один оператор)))
// PascalABC.NET 3.0, сборка 1150 от 22.01.2016
begin
Writeln(ArrRandom(10,1,99).Println.Where(x->x mod 2=0).Average)
end.
Тестовое решение:
96 42 79 85 16 22 50 62 54 40
47.75
"Школьный подход" (видимо, короткому решению у нас не учат)
// PascalABC.NET 3.0, сборка 1150 от 22.01.2016
const
n=10;
var
a:array[1..n] of integer;
i,k,s:integer;
begin
s:=0;
k:=0;
Randomize;
for i:=1 to n do begin
a[i]:=Random(99)+1;
Write(a[i],' ');
if a[i] mod 2 = 0 then begin
s:=s+a[i];
Inc(k)
end
end;
Writeln;
Writeln(s/k)
end.
Тестовое решение:
22 22 58 41 54 80 71 65 47 99
47.2
- 20.07.2017 05:18
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.