Вопрос по информатике:
Составьте программу , которая считывает с клавиатуры n чисел и находит сумму и среднее арифметическое значение нечетных чисел
- 23.08.2018 07:36
- Информатика
- remove_red_eye 7441
- thumb_up 47
Ответы и объяснения 2
Объявим нужные переменные
Нам потребуется sum(сумма), average(ср. арифм), i(для цикла), n(кол-во чисел), x(введенное значение), count(счетчик нечетных)
Присваиваем переменной n(кол-во чисел) нужное значение.
Обнуляем summ и count
Организовываем ввод чисел с клавиатуры через цикл от 0 до n
Внутри цикла делаем проверку на четность, примерно так:
if x mod 2 = 1 then (mod 2 обозначает остаток от деление на 2)
А здесь увеличиваем переменную sum = sum + x
И счетчик count = count + 1
Теперь после того как все итерации пройдены
Переменная sum хранит значение суммы нечетных чисел.
А переменную average надо разделить на count. average = average / count
Так мы получим ср. арифметическое для всех нечетных чисел.
Выводим значение sum и average.
- 24.08.2018 01:21
- thumb_up 2
//PascalABC
//NaaMan
var
N, sum, num, i : integer;
A : array[1..10000] of integer;
SA : real;
begin
write('Укажите, сколько будет чисел > ');
readln(N);
write('Вводите элементы массива > ');
// Обнуляем сумму
sum := 0;
// и количество искомых элементов
num := 0;
// Ввод элементов массива с одновременным подсчетом
for i := 1 to N do begin
// Ввод
readln(A[i]);
write('Ещё > ');
// Если введённое нечётное, то
if A[i] mod 2 = 1 then begin
// добавляем к сумме
sum := sum + A[i];
// и считаем их количество
num := num + 1;
end;
// Это среднее арифметическое
SA := sum / num;
end;
writeln('Сумма элементов ', sum);
writeln('Среднее арифметическое ', SA);
end.
- 25.08.2018 04:24
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.