Вопрос по информатике:
1. Составьте программу, решающую следующую задачу: С кондитерской фабрики отгружают конфеты в коробках по 10 кг, 5 кг и 1 кг. Какое наименьшее количество (K) коробок потребуется для перевозки N килограмм конфет? Вводимое и в ыводимое . Для заданного числа суток определить количество часов, минут и секунд. Вводимое количество сутокВыводимое количество часов, минут, секунд7 суток= 168 часов = 10080 минут = 604800 секунд1 сутки= 24 часов = 1440 минут = 86400 секунд10 суток= 240 часов = 14400 минут = 864000 секунд2 суток= 48 часов = 2880 минут = 172800 секунд
- 06.09.2016 08:32
- Информатика
- remove_red_eye 7398
- thumb_up 17
Ответы и объяснения 1
Вроде должна работать это 1 задача
uses crt;
var a,i,j,n:integer;
begin
writeln('ВВедите кол. конфет в (кг)');
read(a);
n:=0;
if a>=10 then begin n:=n+ a div 10; a:=a-(a div 10*10); end;
if (a>=5) and (a<10) then begin n:=n+ a div 5; a:=a-(a div 5*5); end;
if (a>=1) and (a<5) and (a<10) then begin n:=n+ a div 1; a:=a-(a div 1*1); end;
writeln('Общее количество коробок = ',n);
end.
-----------------------------------------------------------------------------------------------
2 задача
uses crt;
var a,i,j,n:integer;
begin
writeln('Введите кол. суток');
read(a);
writeln('Количество часов в ',a,' сутках = ',a*24);
writeln('Количество минут в ',a,' сутках = ',a*24*60);
writeln('Количество секунд в ',a,' сутках = ',a*24*60*60);
end.
- 07.09.2016 08:22
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.