Вопрос по информатике:
Составить программу вычисления,
A - сумма положительных элементов массива;
B – номер наименьшего элемента массива;
C - количество элементов массива кратных пяти.
Полученные значения элементов А,B,C,W вывести на печать.(Паскаль)
- 07.02.2016 17:50
- Информатика
- remove_red_eye 8433
- thumb_up 24
Ответы и объяснения 1
Program z1;
var
mas: array[1..100] of integer;
i,a,b,c,n,min: integer;
begin
a:=0;
min:=1000;
c:=0;
writeln('Введите количество элементов массива');
readln(n);
writeln('Введите элементы массива');
for i:=1 to n do
begin
read(mas[i]);
if mas[i]>0 then
a:=a+mas[i];
if mas[i]
min:=mas[i];
b:=i;
end;
if mas[i] mod 5=0 then
c:=c+1;
end;
writeln('Сумма положительных элементов массива равна ',a);
writeln('Номер наименьшего элемента массива равен ',b);
writeln('Количество элементов массива, кратных пяти, равно ',c);
end.
- 08.02.2016 13:40
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.